Start a new topic

Installing new Cafetran

Hello,


I have a very simple question. I have an old version of Cafetran and have just purchased the new one. I have downloaded the new trial version and am asked to put it in applications. I have then been asked if I want the new one to replace the old one? Will this delete the memory of the old one? Should I keep the old one?


Thank you,


Claire


Hi, Claire,

>> I have then been asked if I want the new one to replace the old one? Will this delete the memory of the old one?

If the CT that you downloaded before is in the applications folder, it will be replaced by the new one without deleting all your settings.

Cheers,

Thank you!

I just replaced the old one with the new one and now it says I can't open the application. Any ideas?


Thank you!


Claire

If you are a Mac user, please go to Preferences > Security and Privacy, and Permit the downloaded application (sorry, I'm Japanese, so menu wording may not be accurate)

 

Hi Claire,


Your old version probably ran on Java 6 (installed before April 2015) so you need to reinstall CafeTran, which runs on the latest Java 8 now.


CafeTran keeps translation memories (.tmx files) outside the package (in the location where you saved them) so it is only a question of reopening them in the new version. However, I would recommend the following:


1. Remove the previous version (the CafeTran.app file) from the Applications folder and keep it as an back-up for now in case you need any resources which may be located inside that old package.

2. Install the new version and open the tmx memory files which you need in your translation.

3. When you are sure that all your resources are restored in the new version, remove the old version to Trash.


Igor

I'm afraid I can't see where it says to permit the downloaded application. I'm in security and privacy in system preferences.


Claire

Make sure you are using the latest Java 8 on your Mac. CafeTran does not run on Java 6 any longer.

Oh. Thanks Igor. I have installed the latest Java. I then downloaded the new version and put it in applications. I'm afraid I have replaced the old application with the new one (as it seemed that nothing would be deleted). When I click on it, it says The Application cafetran cannot be opened.


Claire

Hi, Claire

It's here.


 

Please submit a support ticket. I will help you there.


A new version of CafeTran downloaded from the website (so not the CafeTran.jar only) will remove:


  • all your settings
  • the database (if any)
  • the spelling dictionaries
  • segmentation rules
  • any other "lists" like abbreviations, .res files, placeables, etc.
You should use Time Machine to copy your old version to say the desktop, and open the CT package. Do the same for the new version in a new Finder window. Compare the contents of:

~/Applications/CafeTran.app/Contents/Java/infos

~/Applications/CafeTran.app/Contents/Java/resources

~/Applications/CafeTran.app/Contents/Java/rules


and copy from old to new.


If you can't open CT, follow Masato's instruction (though actually that shouldn't be necessary for an app that has been installed previously). In English:


Go to  | System Preferences | Security & Privacy | General Allow apps downloaded from, and click Install anyway if you see that option. If not, click the lock to open the Preferences so you can make changes, and select Allow apps downloaded from | Anywhere. Don't forget to change the settings again after CT can run!


H.


> If you can't open CT, follow Masato's instruction (though actually that shouldn't be necessary for an app that has been installed previously).


It is all settled now. The user switched from Java 6 to Java8 and the restart of the system was needed.


Igor

Yes, all sorted. Thank you everyone for your help.


Claire

Login to post a comment