Start a new topic

Spellcheck not working

I have a little problem, in that the spellcheck doesn't work for me with either of the available options (OpenOffice/LibreOffice or Hunspell).


What do I need to do to fix this? Or is this a bug?


I'm on Linux, have LibreOffice installed, but set up to use a different Java version (though it seems unlikely that that would be the problem).



Don't know about OOo/LO (anymore), but did you "install" the Hunspell dictionaries in the right directory?




H.

Hi Hans,

thanks for your reply - No, I haven't installed Hunspell - I assumed it was included with CafeTran.
So how and where (on Linux) do I install it?

Cheers,
Jeremy

I have no idea, but I suppose the path must be similar to the directory on a Mac (see screenshot).



H.

OK, got it (subject to confirmation) - instructions are here: http://cafetran.wikidot.com/installing-the-hunspell-spell-checker

 

And just to elaborate, I installed to cafetran -> resources -> spellchecker.

Igor, since (presumably) the spellchecker must be installed to this directory, shouldn't you take this out of the user's hands?

D'oh! That didn't work as well as I hoped - I've installed the Hunspell dictionaries for en-GB and de-DE, but now it thinks every word is misspelt. The project settings are correct, the target language is set to en-GB. Any idea what I've done wrong?

 

Did you install both the *.aff and *.dic files?


H.

amos: Igor, since (presumably) the spellchecker must be installed to this directory, shouldn't you take this out of the user's hands?


Too many target languages. Although I think OmegaT comes with most/all of them installed.


H.

Thanks Hans, for your input.

To your first reply, yes I (or more precisely CafeTran) did install both.

To your second, what I meant was, where CafeTran installs these for you (via the 'Spellchecker' option on the 'Edit' menu, as set out in the wiki article linked above), it shouldn't require the user to specify the install path. (Since this is an internal CafeTran requirement.)

 

After installing spellchecker files, you have to restart CT.

 

Thanks Masato, but I did that.

 

It seems to be using the German dictionary in the target segment - when I copy German text in there, it doesn't mark it as being incorrectly spelt (until I overtype with English text). I can't find an option to choose the spellcheck language (you'd think it would be determined from the target language).
Anyone?

 

Hi Amos,


It should pick your target language unless you created a project with a reversed language pair by mistake (see Project > Project Configuration) or this is non-CafeTran project where the target language code is not recognized.


Igor

To install a dictionary, open CT and go to "Edit - Spell checker" and click on "Install dictionary".
Before doing so, you should probably remove the spell checker files that you installed previously (unsuccessfully).

Normally, CT automatically chooses the target language as the spell checking language. But at "Edit - Spell checker", you can also choose a different spell checking language/variant.
Login to post a comment