Start a new topic

How to let CafeTran recognise words at both sides of a slash?

This question was asked 2 years ago in the google group. Any solution now?


Copying the post here:


Selcuk

-------------------------------------

On Thursday, 12 September 2013 11:39:33 UTC+3, Hans list wrote:
Dear all, 

I think that I want to change a particular behaviour of CafeTran that I personally don't consider to be productive: the slash forward (/) preventing the recognition of words separated by this slash: 

verylongword/anotherverylongword 

where both verylongword and anotherverylongword are present in my glossary. 

I thought it would be as simple as removing '/' from the Do not match list: 

,.。:;!¡?¿[]()"«»‘’„“”– 

, but this doesn't solve it. 

Any suggestions? 

Cheers, 

Hans

-------------------------------------



Hi Selcuk,


Go to the Edit > Preferences > Memory tab and append the following Unicode number U+002F (forward slash)


in Additional space characters field: U+00A0,U+002F


These Unicode numbers separated by comma define additional word dividers. The list may be either comma or space separated:


U+00A0 U+002F or U+00A0,U+002F


Igor



1 person likes this

Thanks Igor,


It works :) I was not sure about adding a / character or U+002F in the Do not match box (or separate it with a comma or space) but it worked.


Cheers,

Selcuk

Do not match field should be left unchanged without U+002F there.

For future reference it will be better to add it here:



Thanks,

Selcuk

Hello,

In relation to this, when U+002F is added, is there any way to let CT not ignore a slash in specified cases, such as "10 euros/hour"?

 

Cheers,

Well, that is a problem as well.


 

See http://cafetran.wikidot.com/changelog


2013-11-11
 Previously, a slash character (/) would prevent neighbouring term recognition. You may now treat the slash as an additional whitespace character (a word separator). To do so, enter its Unicode character ‘U+002F’ (‘SOLIDUS’) here: Edit > Options > Memory > Additional space characters (Unicode numbers) to enable neighbouring term recognition. Note that the slash currently has to be reinserted into the target manually:http://www.screencast.com/t/TepR3zNXFalD 



Thanks!

 

Perhaps we should add the apostrophe U+0027 as an additional space character too. Otherwise CafeTran will fail to find, e.g. season's.


But what will be the other consequences of adding apostrophe to the list?


Cheers,

Selcuk

Hi Selcuk

It you want CT to find "season's" as "seasons," this apostrophe should be added in "Do not match," not as an additional space character.


Cheers

"season" in glossary, but CT does not display it.

.......... season's favourite .......


When I add the apostrophe U+0027 as an additional space character CT displays glossary result for season. 


Oh, I didn't notice that.

 

>Note that the slash currently has to be reinserted into the target manually:


It would be awesome if you could find the time to have the forward slash re-inserted automatically, Igor!



Sure, it would be awesome if I found a way how to do it.


Igor

Perhaps a work-around is possible. Surround the forward slash with spaces at the source side, also in sdlxliff. Will test this.

Login to post a comment