CafeTran Espresso 2016 Harbinger

Hi all,


It is my pleasure to announce CafeTran Espresso 2016 Harbinger available for download. The users who purchased the program after 22 April 2015, in the new licensing system, do not have to install it anew. They can update it via a simple drag and drop procedure as follows:


1. Run CafeTran.

2. Download 20151127_update.zip file from here (do not unzip or rename the file after downloading) and place it on your desktop.


Note: On Mac OSX, the Safari web browser may unzip the file automatically after downloading. To prevent this, just use the right-click menu and choose the "Download Linked File" command.


3. Drag and drop the downloaded file into the Project Dashboard and restart the program.


4. Drag and drop the downloaded file into the Project Dashboard and restart the program. Second time!

    The step 4 above is only for users who missed the update 10 with the new icon sets.


The update includes the following changes:


1. The new word/characters count in the Statistics function diplaying the speed of translation in CafeTran running session.

2. The new option for subsegment matching called "Subsegment hits threshold" to reduce the display of low-quality subsegment matches. The default value is 3 which ensures the hits below this number are discarded.

3. The machine translation panes get two new buttons to let the user transfer the MT translation to the target segment and repeat the query with the selected fragment in a more intuitive way.

4. Localized formating of numbers can also take place when the numbers are inside parenthesis.

5. The fix in the typing of accented characters in Portuguese on Mac OS X.


As we approach the year 2016, I think it makes sense to change the name to CafeTran Espresso 2016 Harbinger. This 2016 version of CafeTran is also the summary of all the improvements, changes and fixes made this year.


Have a nice weekend!

Igor


Yes, that's how I feel it too.


Same wishes to you!

>> 4. Minor interface and terminology changes discussed on the forum and aimed at making CafeTran the intuitive tool.



 I'm late enough to understand what is meant, today.

After having tried the Harbinger preview for weeks, I now feel that the glossary pane sometimes takes too much space (i.e., when there are many synonyms), and this makes it somewhat difficult to find the term I'm looking for.



I'm happy to be able to see all the synonyms at a glance, but in practice, not all of them are always relevant.


So, a better device might be to show the matched term only (as was done by all previous versions) while implementing a tooltip that shows all the synonyms (like the one you see on a TM pane).

Absolutely true! CafeTran's getting more and more intuitive. The approach to hide things until they are necessary is nice. I think that Apple uses it too in its software.

 

>> Thank you for noticing this! It has been the highest priority recently.



Please apply this good approach to the glossary pane, too.


Cheers,

 

Masato: ...but in practice, not all of them are always relevant.


In practice, only one of them is relevant. The one you're going to use. To achieve that you'll only end up with the relevant term, you can tweak your termbases, and use Auto-Assemble. And if you have that AA result inserted, you won't even need that third line you're advocating.


REQ: I think Igor should implement it. It would be very innovative.


H.

Hi, Woorden

I forgot to thank you for your support.

Cheers!

 

Hi all,


Taking into account our recent discussions concerning the menus, I have made a few changes and uploaded the harbinger (preview) version of CafeTran 2016 (build 2016010401). If you wish to test it, please repeat the update procedure described in the first post in this forum thread.


Furthermore, I've added the following functionality to the auto-propagation feature:


- auto-propagation of segment with different numbers.

- auto-propagation of segments with different non-translatable fragments.


The two auto-propagation options are on by default and can be turned off in the new Auto-propagation tab (see Edit > Preferences > Auto-propagation tab).


Cheers,

Igor 

Hi Igor,


I am not sure about a separate Action menu. I would normally expect to see them under the Translate menu. This applies to many of the actions under the Task menu as well.


Edit > Target Segment submenu is not complete on the other hand. Some related commands are under Task menu. Please consider me a newbie, and I am lost in the menus.

I am not sure about a separate Action menu. I would normally expect to see them under the Translate menu. This applies to many of the actions under the Task menu as well.


To avoid very long menu lists and multi-layered sub-menus, I split the former Translation menu into two main menus (Translate and Action) so that the user would get a faster access to the basic commands. I hope it is just a matter of getting used to for long-time users.


Igor 

This is very nice!

Screenshots for those who want to see some of the changes without testing:


 




And, we have "All" now:



IK: ...I split the former Translation menu into two main menus (Translate and Action)


More features = more Menu items. There's little you can do about it.


Some time ago, I suggested to split CT up, either in separate (but linked) apps, or in "virtually" separated apps, each with their own menu. Like:


Prepare document → Settings Translate → Review → Finalise → Export translation/Resources → Maintenance


or more or less steps. I have no idea if Igor is able to do this, and I also have no idea if it "works" for the translator. But it would reduce the number of items in the Menu, and I suppose it would help the translator to concentrate.


Talking about concentration, more recently, suggested to use Recall Segments to get rid of "crap" (okay, useful crap) of them glossaries, while still being able to access synonyms, hyperlinks, words in other languages, operas and symphonies, and diagrams when you need them in the very same database table as the one that recalled the segments. In the translation stage - when you go from segment to segments - you don't need them if your settings are okay, or you at least don't need them every time you go to the next segment.


Simplicity out of necessity H.


I vote for the idea that the menu and sub-menus should be arranged in line with an ordinary translation process: prepare, settings, and so on. Much easier to understand, especially for newbies.

Cheers,

 

Hi! I'm just testing the latest update of the preview version and found that in the Project Configuration dialogue, there's no more "Project glossary" or "ProjectTerms" option on the "Project memory" tab. I've found that such an option can sometimes be useful, if you've forgotten to select the "Project glossary" in the Project Dashboard. Is there any chance of the option in the Project Configuration coming back?

It shall come back!

Hi,


Today I have uploaded one of the last updates before the official release of CafeTran Espresso 2016. The changes are as follows:

  • Significant simplification of the menu interface. The menus with the power features can be activated/deactivated now when you need them in your workflow. See the View menu.
  • The new Match bar can be floated (see the menu View > Toobars > Float Match bar). It can let translators use CafeTran resources and features while working in the other applications such MS Word, PowerPoint, Excel, etc.
  • The results of auto-assembling (subsegments, terms, fuzzy matches) can be directed to the system clipboard. See the menu Edit > Preferences > Auto-assembling > Copy matches to clipboard.
  • A new command in the menu Edit > Copy target segments to clipboard. When this option is activated, each target segment is copied to the system clipboard.

The update (build 2016010701) can be performed via the usual drag and drop with the same download file as described at the start of this thread.


Have a nice weekend,

Igor  

Login to post a comment