Start a new topic

Number conversion: 0.50 > 0,5

The number conversion works fine, but it is converting any number with a trailing decimal zero just as follows:

0.50 becomes 0,5

0.60 becomes 0,6

From a mathematical point of view absolutely correct, but this is not what I want (and what most other translators won't want). Bug or feature? Or did I muss any checkmark anywhere?

BTW: QA numbers will report errors for the missing zero.

Ah, found it (after reading a post of Igor's): I have to set the correct source language. Which sounds logical :).

After setting the source to en-GB, the results are:


Is there a way to have the last line localised to Dutch?

I have reset all Preferences and then set the AA settings to:


No comma/point conversion is taking place. Why is this?

Test document attached.

(12.7 KB)

I'm glad to report that number localization now works like a charm here. 


Please tell that Will. I unsubbed from the forum of the Thieves of Mountain View.


Not my fault, Will's got no progressive lenses. ;-)

Thanks Woorden

Wolfgang, borrow that Will's glasses, and look at my message exactly above yours.


Just discovered this threat...

Anybody here to explain how to activate number conversion from EN: 10,000 to DE 10.000?

Thanks i.a.


woorden: Might be useful. Will try.

I tried. It's useful. My excuse for not having tried it before, is that I've been using CT for only 5 years.

In the menu, Edit | Options |Auto-Assemble, enable Format numbers.

(and enable AA, of course, maybe, I think).

To prevent segments with only numbers, or with only numbers + a unit, just click Next Segment (as above), or use the relevant shortcut. You can "Jump Over" segments with numbers or segments with no letters. You can also filter first on Segments with no letters.

I translate from both English and German to Dutch, so I should somehow remember to turn of Format Numbers if the SL is German, although it's quite possible CT discovers this automagically.


T RE: You are right.


Get used to it.


So we are back to CT.


Unlikely, unless you checked Format Numbers in Options | Auto-Assembling (and enabled AA), and there you didn't find anything, you said. I don't know what Format Numbers does, because I don't use it, mainly because I didn't even know it existed. Might be useful. Will try. In the meantime, have a look at your regexes again. They stink (in CT).



You are right. I remembered having inserted something into my NTs concerning numbers, but I must be wrong (I just checked again).

So we are back to CT.

|w+\.(\w)+(-)?(\w)*\.\w+ looks like it searches for a URL. But whatever it does, it cannot do anything to your numbers, because the second part (the "Replace" part) is lacking. So you'll have to look for other candidates.


In case of doubt, blame the regex. You can't do comma<>dot conversion with a simple regex. You'll need a three steps regex, and then there will still be things that will go wrong. Stay away from regexes.


Sorry, I need to correct my post. It might be just another problem, and not a CT bug.

I have


in my non-translatables and the automatic transfer of NTs is on.

The question is: Is the RegEX erroneous or does CT do this?

0,50 is more precise than 0,5, because the latter can refer to 0,5499999[recurring].

But anyway, which conversion do you use?


Login to post a comment