Start a new topic

Reloading user's spelling dictionary

What do I need to do to reload a user's spelling dictionary.


My workflow:

  1. Task > List words with unknown spelling
  2. Edit > Edit user's spelling dictionary
  3. Search the list & correct the text in the grid where appropriate
  4. Copy all "positive" errors into the user's spelling dictionary
  5. Close both lists, saving the user's SD of course.
  6. Close CT and open it again
  7. Task > List words with unknown spelling
  8. Edit > Edit user's spelling dictionary

Problem: the lists under 1 und 6 are the same, despite of the correct spelling that has been added to the dictionary in 4 and that is really showing up at 7. Same problem with doing a QA for spelling errors – the elements in the user's dictionary are not recognized.


I assume this is the problem to reload the user's spelling dictionary, but what do I need to do? Restart the whole system?


Hi Torsten,


It works without problems here. Are you sure that user's spelling dictionary is saved with new entries?


Igor

If I remember correctly, when closing the tab (custom dictionary) CafeTran doesn't offer you to save the file first. Which it should, of course.

Well, I even did a restart of the whole Mac (latest Java release, El Capitán, but I remember the same thing for Yosemite)) and the words are inside the user's spelling dictionary – just as before – but again they are marked as spelling errors (by any means: underlined, in the list of unknown words and when running a "manual" spell check QA).


@Hans: After the point 4, I press always Cmd-S – pure instance – and indeed the file has been changed and remains changed, as mentioned above. By the way: When closing the list of unknown words, there is always the dialogue window if it should be saved. I do not know if this dialogue window is really necessary, but this is another question.

Eh, instinct, not instance ...

I tested it again today with the newest build, but it keeps marking the words although they are in the user dic. Even after restarting CafeTran.

 

If there exists a user dictionary with your target language extension, it looks for user's words in this spell-checker dictionary.

Strange:
The Spell check on Mac does not recognize the user dictionary.

After having copied the same words into the user dic on Linux, spell check tells me there are no errors (all unknown words had been copied to the user dic), but all words not in the user dic keep being underlined in red.

 

You may not have installed the spell-checker dictionary for your target language on Linux. The implementation and the spell-checker files are exactly the same on both systems. 

The spell checker is definitely installed (see below, I assume this is a proof).

image


Verlängerungsstück is in the user-defined dictionary. The spell check is completed successfully, but it also does this after misspelling a word.

Tried again with the OO spell check extension. Nope.

 

Verlängerungsstück is in the user-defined dictionary. 


How did you add it to the dictionary? Via the right-click or editing the file directly?

I added them by editing the file directly (and closing it). But on the Mac I can see there also the last words I added by right-click, so it cannot be a read write problem (on the Mac, CT is in the programs folder, on Linux in the home/torsten folder).

Mac side: Very probably solved. The user dictionary contains an arbitrary number at the start. Yesterday I deleted this (three-digit) number and it did not work. Today I did not delete this number („1“), and it works, also in the project of yesterday.

I wil try again on the Linux side later on.

The number isn't arbitrary: it's the number of lines minus one (for the header). The engine stops reading the list after the number indicated.

Login to post a comment