Start a new topic

Battery drain & CPU usage.


I'm experiencing an issue with Cafetran's resource use. I'm using a 2014 Retina Macbook Pro with i5 2,6 GHz, 8 GB of RAM and a solid state drive running the final build of El Capitan 10.11. The laptop is still pretty new and maintains a stable 8-9 hour battery life (~120 load cycles) while using Safari, MS Office and other simple, everyday tools.

However, using Cafetran decreases the battery life to approximately 2,5 - 3 hours, the fan fires up to more than 3,000 rpm (idle value = ~1,300), also the temperatures rise considerably. I've already tried changing the autosave setting value for glossaries, projects and memories to 10.
At the moment I'm using a single TMX memory consisting of little less than 12,000 entries and a couple of glossaries with several hundred terms.

I'm using the full version of Cafetran, revision 2015101301 released today and I have the newest java 8 installed.

The above happens regardless of the translated file's size. It makes no difference if the document contains five thousand characters or a hundred thousand.

I'm attaching a screenshot of the Activity Monitor's energy tab, with the second and third columns being Energy Impact and Average Energy Impact. That's after ten minutes of working in Cafetran. CPU Usage stays between 15 and 20%.

I had the same issue with older revisions of Cafetran on my old 2010 Macbook white running Mavericks and, later on, Yosemite. However, it wasn't that much of an issue since that laptop wouldn't last more than two hours on a single charge anyway.

As my hardware finally allows to spend more than a couple of hours away from the wall socket, it would be great to take advantage of it.

I would be very grateful for any help on this matter.

...or is it supposed to be like that?


Repeated the test on my MacBook Pro 13" with 16 GB RAM, Core i7:

The idle processor load for CafeTran dropped to 2% after setting both Xms and Xmx values to:



On the Energy tab in the Activity Monitor, CafeTran only takes a few precent.

Using a fresh CafeTran, default settings, except for the values above.


During my "stress test" I made a mistake and F/R in my TM instead of in my project :). That really got my MacBook Pro working:

I just tried



and it makes no real difference on my MacBookPro, under El Capitan.

The only way to use less CPU here is to minimize CT. Than it drops from around 15% or 16% to below 2%. Not very pratical though :D 

Alain, we are talking about the idle processor load here. Did you switch to another app?
Hi Hans,

Yes I did. If I keep CT's window opened in the background, it uses around 15%. It drops to below 2% if I minimize the Window in the Dock.

I happened to stumble on an article that may provide a solution for the nasty problem of battery drainage and hot MacBooks: Kill the CPU turbo feature. I haven't tried it (no MacBook), but it may affect performance. There's a free and a paid version.


1 person likes this

Please see the solution in the following thread:

and the new tip in the article here.

Hi, for me (MB Pro 2018), the key was really to use the the metal look and not the Mac OS look!

The difference in energy use (and surface temperature) is huge!!

Thanks a lot

Login to post a comment