Start a new topic

Help! CafeTran (Mac) won't start ...

Hi! 

I recently downloaded the trial of CafeTran for Mac and spent a few hours working with it - I was very happy with the software, and was thinking of buying a licence after a few more days' tinkering.

I came back after the weekend, and unfortunately CafeTran won't start up. Its name appears in the top bar, and a blank window opens ... but then it freezes totally. 

Can anyone help please? I uninstalled and reinstalled CafeTran a couple of times - no luck. I also did the same with Java. 

The only thing I can think of is that I recently transferred all of my work folders over to a Dropbox folder. At the same time, I deleted a few files which I thought were from my trial of WordFast, but could have been CafeTran files. Have I deleted some necessary directory by accident? I can't understand it - it was working so perfectly before!

I also have no idea where my work is stored - can anyone please tell me where it might be saved? (I don't know the file extension for CafeTran files so can't search for them.) 

Thanks very much for your help.

Jon


Exactly the same happened to me some time ago. Upgrading to Java 1.8 solved the problem. To check the version, in the Terminal, run java -version


CT project files have the extension .xlf


H

I'd also advise to click the Reset button in Edit > Options.

About the Terminal command: this doesn't always work. (I get the request to install Java.) Alternatively you can open Sys Prefs and check there:



@Woorden & @Hans thank you very much for your quick responses!

I updated Java from various sources and it's still not working, I'm afraid. Although there's a slight discrepancy in the info I'm getting about which version of Java I have ...

If I go into sys preferences, it says I've got the same as you, Hans - v8, update 60, build 1.8.0 etc.)

but if I type java -version into terminal, it tells me a different story:

java version "1.6.0_65"

Java(TM) SE Runtime Environment (build 1.6.0_65-b14-466.1-11M4716)

Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-466.1, mixed mode)

any ideas? thank you so much for your help - i'm very grateful!

(also @Hans - I'm afraid I can't get to the Edit menu to click reset in Cafe Tran) 

Well, if Jon is confronted with the very same issue I had (running CT results in a white screen), he can't Reset CT.


I had a lot of trouble with it, and it only worked after I downloaded the latest CT build, and the JDK version of Java.


The Terminal:


Hans-van-den-Broeks-Computer:~ hans$ java -version

java version "1.8.0_45"

Java(TM) SE Runtime Environment (build 1.8.0_45-b14)

Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)

Hans-van-den-Broeks-Computer:~ hans$ 


H.

this is all I'm seeing when I try to open CafeTran

Jon: this is all I'm seeing when I try to open CafeTran


Too familiar...


H.

@woorden - ok, sorry, didn't know about the JDK version of Java! just downloading it now :) 

Jon: didn't know about the JDK version


Neither did I. And I still don't understand why it helped, or seemed to help (Igor even thought it was the cause of all misery, and I also don't really see a reason to install the JDK rather than the JRE). What could be the case, however, is that the SDK uninstalled or overwrote JRE 1.6.


H.

@woorden - you're right, it overwrites JRE 1.6 - the terminal now says the right thing ...

java version "1.8.0_60"

Java(TM) SE Runtime Environment (build 1.8.0_60-b27)

Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)

I restarted my mac and reinstalled CafeTran, but I'm afraid it still isn't working (I have no idea why - it was perfect before the weekend!)

thanks so much for your help.

Hi Jon,


Please reset program's settings as follows:


1. Download the CafeTran.app.zip file from here:

 

https://dl.dropboxusercontent.com/u/56031844/CafeTran.app.zip

 

2. Unpack it on the Desktop and run it.

 

It should reset the settings.

 

3. Close the CafeTran.app on the desktop and try running the original CafeTran.app which you downloaded from the website.

 

4. If all is working, remove to trash bin the CafeTran.app from the Desktop.

 

Igor

Thank you Igor! that is wonderful - it's sorted out the problem perfectly (and I still have all my work!)


thanks for your help, and everyone else's

congratulations on the software - I'm excited to carry on using it.

Cheers, Jon

Update 7 includes a solution for problems like these.

Hans CafeTran Wiki: Update 7 includes a solution for problems like these.


Apparently not. Just ask Alain.


H.

Login to post a comment