Start a new topic

Segment patterns don't work directly before a period

If your segment pattern is directly followed by a full stop, the last placeholder isn't auto-assembled.

Hi Hans,

It's OK on my Mac ... provided that the source segment has exactly the same structure including a full stop.

Just to make sure, I tried a segment pattern with a full stop followed by a space, and it worked.



A follow-up.

Today, I encountered the same problem as reported here.

Probably, this is related to "Do not match" in Options > Memory.

As I mentioned elsewhere in this forum, "Do not match" seems to be ineffective for segment patterns (every bit of information must match); but I may be mistaken.

Certainly, a clarification from Igor is necessary for this issue.

My personal request is for CT to at least disregard the period, semicolon, colon, and other end-of-line/segment markers when searching for pattern matches (if they are not disregarded now).

Having started a new topic under the Tips and Tricks category, now I think I should withdraw my request.


Login to post a comment