Start a new topic

Problem changing "Read only" status of memories

Hi everyone!

I'm having a problem with a TMX memory that I opened as a "Read only" previously. Now I'm trying to open it as a read/write memory to merge it with another one. When I choose "Memory - Open memory", the usual settings dialogue appears. I leave the "Read only" box unchecked, but the memory opens as a read-only memory nevertheless. So changing/saving it is not possible. I tried to use the "Save memory as" option from the "Memory" menu, but I only get a warning that it's a read-only memory.

I also tried opening the memory as a "Edit TMX memory" project. It opens, but obviously it can't be saved (after saving, the file size is only 1 kb and it obviously doesn't contain any data).

I tried the same thing with a different memory that was previously "Read only", but the results were the same.

Does anyone have a solution for the problem, or will we have to wait for a CT update?

TIA for your answers!


If you open it in a text editor, what does it say in the header:

<header creationtool="CafeTran" creationtoolversion="2.0" datatype="plaintext" segtype="sentence" o-tmf="CafeTran TMX" adminlang="EN-US" srclang="nl-NL" creationdate="20150818T175005Z" creationid="MICHAEL BEIJER" changedate="20150818T201638Z" changeid="MICHAEL BEIJER"><prop type="x-segments">false</prop><prop type="x-terms">false</prop><prop type="x-processing_tags">false</prop><prop type="x-read_only">false</prop><prop type="x-pretranslate_only">false</prop><prop type="x-terms_consistency_check">false</prop><prop type="x-priority">0</prop><prop type="x-integration">0</prop><prop type="x-case_match">true</prop><prop type="x-duplicates">1</prop><note>size=38515</note>



Is it a TMX that you created in a older version of CT? Igor recently changed CT, and TMX settings are now stored in the header of the TMX. Th't the case previously.



No, the TM is not that old, at least I updated it at the end of July. And it does contain the new header.

Well, in the meantime, I tried some other things, and this recent thread from the CafeTranslators group gave me an idea. It said that you can change the "Read only" status by opening the TM from the Project Dashboard. So I unchecked "Read only" in the Dashboard TM settings, created a new translation project and selected the TM together with it - et voilà, the status reverted to "read/write".

Now my question is: Can you open a TM from the Dashboard without opening a translation project at the same time? Obviously, opening it via the "Edit TMX memory" option doesn't help. BTW, I also tried using "Edit TMX memory" and then choosing "Project configuration -- SWITCH" and unselecting "Read only" in the settings dialogue that appeared. It didn't help; it only made all the memory entries disappear.

Now here's a suggestion that's just come to my mind: In my opinion, it makes sense to always open a memory in read/write mode when you choose "Edit TMX memory" because the read-only mode doesn't make sense if you wish to edit a memory.



Today again: different TM, similar problem.

The "Read only" status wouldn't change, not even if I opened the TM via the Project Dashboard. The only solution for changing the status in CafeTran (i.e. without editing the TMX file in an editor) was to create a copy of the TMX file (with a different name) and open the copy from the Dashboard. Then I finally had a read/write TM that I could merge with another.

BTW, I remember quite clearly that the problems I'm having now didn't occur before the last CT update.



Here's another suggestion for the memory settings: It's good that CT now remembers all memory settings and stores them in the memory itself. But a very helpful improvement would be if it were possible to change memory settings at any time even for read-only memories. 

booh, this is happening to me today... not possible to revert the read-only status...

Any suggestions since the last ones?


yes, using the path of having to exit the project and changing from the dashboard works, but I wonder if then the workflow must be to make copies everytime we want to use a tmx file as read-only...

As far as I know, you don't have to quit CT. Just "delete" the Read-Only TM, and "open" it again from the Menu. A dialogue will appear in which you can change the R-O status.

NBr: But a very helpful improvement would be if it were possible to change memory settings at any time even for read-only memories

Impossible, since it's R-O, and nowadays, CT saves the TM settings in the TM file itself. You can't have it all.


 Since Update 5, it's possible again to change the memory settings when opening the memory via the "Memory" menu (with the previous update, that was impossible). That's great, but indeed, the possibility to change settings of any memory at any time would be ideal.

You can change the settings of a connected TM, with the exception of Read-Only TMs. And that makes sense.

[You also can't edit forum entries...]


Login to post a comment